System Requirements and Required Software

In order to receive technical support from Excelsior College, you must meet our minimum system requirements.

Operating Systems

A note about Windows operating systems: Microsoft periodically ends support for its older operating systems. Our minimum computer system requirement in the chart below reflects these changes.

Web browsers

Web browsers listed in the chart below have been tested and validated for use with our Website. Other web browsers not listed may not work as well. We strongly recommended that you use one of the supported web browsers.

System Requirements

 
All computers
Minimum
Recommended
Monitor
15" VGA
256 colors
800x600 resolution
17" SVGA
True color
1024x768 resolution
Internet connection
56K modem
Broadband (cable or DSL)
Email capabilities
Email address (required)
Email address (required)
Web Browser Plugins
Adobe Flash® Player 11
Java 71
Adobe Flash Player 11
Java 71
Software
Adobe Reader X
Adobe Reader X
Window Computers
Minimum
Recommended
Operating System
Windows Vista
Windows Vista
Windows 7
Windows 8
Web Browser (only one needed)
Internet Explorer 8.0
 
Internet Explorer 8.0 
Internet Explorer 9.0 
Internet Explorer 10 
Mozilla Firefox 
Google Chrome
Word Processing Software (only one needed)
Microsoft Word 20033
Microsoft Word 2003
Microsoft Word 2007
Microsoft Word 2010
Microsoft Word 20013
 
MAC Computers
Minimum
Recommended
Operating System
Mac OS X 10.6 (with Java 6)1
Mac OS X 10.6
Mac OS X 10.7
OS X 10.8
Web Browser
(only one needed)
Safari 5.1.9
Safari 5.1.9
Safari 6.x
Mozilla Firefox
Google Chrome2
Word Processing Software
Microsoft Word 20113
Microsoft Word 2011

 

1 On Mac OS X 10.6 computer Java updates are provided by Apple through Mac Software Updates, available on the Apple menu. Java 7 is not supported or compatible on Mac OS X 10.6 computers. Check that you have the most up-to-date version of Java 6 installed on your Mac. For instructions on how to access the Mac Software Updates on your Mac computer, please review the instructions at Apple Support.

2 Chrome is a 32-bit browser. A 64-bit browser (i.e. Safari or Firefox) is required to run Java 7 on Mac OS X. 32-bit browsers such as Chrome do not support Java 7 on the Mac computer.

3 Excelsior College currently supports the use of Microsoft Word for use in our courses. More information about Microsoft Word can be found at Microsoft Word.

Blackboard Learn Support Pages

Excelsior College currently uses Blackboard Learn as its course management system. Therefore, Excelsior College adheres to the same system requirements and web browser software that Blackboard supports. For more details and information regarding the web browsers and software Blackboard supports, you can visit Blackboard Support & Help Pages.

Download Java Software

You will need to have Java software installed in order for certain areas of the courseware system to function properly. Visit general questions and install information to learn more about the Java software.

Not sure if you have Java installed?

Windows Users

Verify your Java version. Note: if you recently completed your Java installation, you may need to restart your browser (close all browser windows and re-open) before verifying the version.

Mac Users

Attention: Due to recent changes to the Apple OSX Operating System, there have been changes to how Java is maintained for Apple Computers.

To update Java for Mac OS X 10.6 (Snow Leopard), please use the Software Update… option available through the Apple menu (located in the upper left corner of the screen) on your Mac computer to ensure you are using the most updated version of Java 6.

Note: Java 7 is not compatible to run or install on Mac OS X 10.6 computers

On Mac OS X 10.7.3 (Lion) or later, Java is no longer provided via the Apple Software Updates. To update/install Java, please download Java for Mac OS X.

Please note that Apple computers running OSX 10.6 or earlier, will not be able to run Java 7 or later.

Download the free Adobe Reader plug-in

In order to view PDF documents, your computer must have the free Adobe Acrobat Reader installed with the latest version available for your operating system.

Use the Get Adobe Reader link below to download the plug-in, then follow the installation instructions available on the download page.

Get Adobe Reader


Download Adobe Flash Player

Some areas of our Web site and online courses contain animations or videos. To view these interactive components, your computer must have the latest free version of Adobe Flash Player installed for your operating system.

Below is a link to download the free Flash Player. Installation instructions and support information are available on the download page.

Test your Flash player here.

Get Flash Player